How to connect a new domain to your Managed WordPress website

domain-connect-managed-vi-en

Using a real domain, your website will get found better in search engines. With Managed WordPress, you can assign a new domain easily from the 1&1 App Center. All WordPress database adjustments and domain settings happen automatically in the background.

Open the 1&1 App Center in a new browser window. Here you can set up the new domain for your website in just a few steps.

  • Click Change domain in the detail view of your website.

app-center-change-domain-mwp

  • Select the domain or create a subdomain for your website and confirm your changes by clicking Change domain.
    Creating a subdomain is easy: simply enter something like my-subdomain.my-domain.com in the text field.
app-center-change-domain-select-domain-mwp

That’s it! The new domain is now connected to your website. The automatic domain setup usually only takes a few seconds to a minute.

You might also like

Please rate this post :

14 thoughts on “How to connect a new domain to your Managed WordPress website

  1. Rob says:

    when I enter my domain it will not allow me to click Publish Website. This UI is so frustrating

  2. 1and1help says:

    Hi Rob,

    Sorry for any frustration our system has caused.

    Looks like you were able to connect your domain in the end. If you still need help, don’t hesitate to contact us.

    Thanks and best,
    Michael, 1&1

  3. Nick says:

    I’ve been able to connect my hosted website to my 1&1 registered domain but I’m unable to connect it to my redirected URL from another provider. Ideally I want to connect my website to two domains (co.uk registered externally and .com registered with 1&1.

    1. 1and1help says:

      Hi Nick,

      to connect the external domain directly to your installation, you have to order this domain as an external domain:

      http://help.1and1.com/domains-c36931/transfer-domains-c79823/to-1and1-c37567/point-your-domain-to-1and1-name-servers-a594802.html

      Btw: From a SEO point of view, It’s not a good idea, to point 2 domains directly to the same content. I would recommend to work with 301 http redirections for one of the domains here.

      Best,
      Michael, 1&1

  4. Nick says:

    Hi Michael,

    I’ve done that but its still showing the status as “Setting Up” in My Domains and I’m not able to connect it to my 1&1 App Centre WordPress site?

    1. 1and1help says:

      Hi Nick,

      at the moment the external domain is in our system with the default 1&1 nameservers. If you want to use these settings as displayed in the domain/dns section of your 1&1 Control Panel, please get in touch with the other hosting provider, and let them save our nameservers on their side (see the yellow box at the end of the linked article in my last comment).

      As soon as both side’s nameservers are synced, the status changes to “Ready” in our system and you can use the domain as described.

      Best,
      Michael, 1&1

  5. Nick says:

    The 1&1 default DNS’s in my settings are different to those in the help article.

    My Default 1&1 DNS Settings
    Name server 1 : ns-uk.1and1-dns.co.uk
    Name server 2 : ns-uk.1and1-dns.biz
    Name server 3 : ns-uk.1and1-dns.com
    Name server 4 : ns-uk.1and1-dns.org

    DNS as per help article
    DNS1: ns-us.1and1-dns.com
    DNS2: ns-us.1and1-dns.us
    DNS3: ns-us.1and1-dns.de
    DNS4: ns-us.1and1-dns.org

    1. 1and1help says:

      Please use the ones you see in your control panel.

      Michael, 1&1

  6. mary says:

    hello,

    I was able to use my domain in wordpress through 1 and 1 control panel. but my problem is orignally my domain is –marialiwanag.com– but now that is connected in my wordpress it kept showing
    — marialiwanag.marialiwanag.com —
    I don’t understand how did it happen. I want it to be
    http://www.marialiwanag.com–

    please help!
    thanks!

    1. 1and1help says:

      Hi Mary,

      whenever someone is typing your domain name with “www.” she will be redirected automatically to the url without “www.”. Thats not an issue and only a cosmetic thing. But technically it is reachible with or without “www.”

      Best,
      Michael, 1&1

  7. Dami says:

    And am also unable to login into the wp admin area. please help me.

    1. 1and1help says:

      Hi Dami,

      in the mean time this should work. Can you please re-test?

      Thanks,
      Michael, 1&1

  8. George says:

    Would you have instructions on using your hosting product without transfering the intended domain and without moving DNS servers to 1and1 if that’s possible.
    Thanks

    1. 1and1help says:

      Hi George,

      for this use case you have to order the domain as an external domain: http://help.1and1.com/domains-c36931/transfer-domains-c79823/to-1and1-c37567/point-your-domain-to-1and1-name-servers-a594802.html

      Instead of using the 1&1 nameservers you can add your external nameservers then: http://help.1and1.com/domains-c36931/manage-domains-c79822/dns-c37586/use-your-own-name-server-for-a-1and1-domain-a594904.html

      Best regards,
      Michael, 1&1

Leave a Reply

Your email address will not be published. Required fields are marked *