Protecting WordPress with SSL was never easier: Managed WordPress by 1&1

SSL WordPress - Activate

SSL encrypts all data that your website exchanges with visitors. It protects important data such as personal data, login data, credit card information and e-mail addresses. SSL improves user confidence and your search engine ranking. 1&1, working together with you, strives to make the Internet a safer place by including powerful SSL encryption with all products.

Security must be easy to achieve. That is why you can activate SSL for your Managed WordPress websites conveniently from the 1&1 App Center*:

  1. Open the 1&1 App Center.
  2. In the website detail view, click Activate SSL.
  3. Accept the SSL guidelines to activate SSL for your website.

We adjust your domain and WordPress settings automatically for SSL. To make sure that your visitors always use an encrypted connection, HTTP traffic will be redirected to HTTPS automatically from now on. The initial setup usually only takes a few seconds and you can continue using your website seamlessly.

WordPress SSL - App Center

* This feature is available with all new Web Hosting contracts and will be available soon for existing contracts.

SSL is included with your Web Hosting contract

1&1 SSL Starter: for blogs and personal websites.

  • Protection for a domain or subdomain
  • With a Wildcard Certificate: Protection of an unlimited number of subdomains
  • 1&1 SSL Starter is a domain validated (DV) SSL certificate.
  • DV SSL certificates are perfectly suited to protect projects such as a blog or personal website.

WordPress SSL at a glance

  • SSL certificates allow encryption of important, confidential data. A requirement for successful e-commerce and social websites.
  • Your visitors can easily recognize SSL/HTTPS encryption in their browser.
  • SSL encryption increases your website’s security and creates trust that can turn visitors into customers.
  • SSL encryption leads to a better position in the Google hit lists for your website.

Learn more about WordPress, SSL and SEO

Please rate this post :

37 thoughts on “Protecting WordPress with SSL was never easier: Managed WordPress by 1&1

  1. Karen says:

    How do I update to the latest WordPress version 4.6.1?

    1. 1and1help says:

      Hi Karen,

      if you are using Managed WordPress, the update was already rolled out from our system.

      If you are using the Standard installation or installed WordPress manually on your webspace, you will be notificated by WordPress in your WP-Dashboard. Security updates like 4.6.1 should also be automatically installed by WordPress itself.

      If you are using a very old version of WordPress you might find instructions here: https://codex.wordpress.org/Upgrading_WordPress_-_Extended_Instructions

      Please be extremly careful in this case – performing backups of your WordPress webspace data and MySQL database before upgrading is highly recommended!

      Best regards,
      Michael, 1&1

  2. Kevin says:

    How do I get the destination to be the SSL version? Currently, just typing in the web address takes me to the non secure http site.

    1. 1and1help says:

      Hi Kevin,

      looks like you are not using the 1&1 Managed Mode for WordPress. In a standard installation, you have configure this by yourself via WP Dashboard, MySQL and additionally in your .htaccess file.

      This manual should help you: https://givewp.com/documentation/resources/how-to-use-ssl-and-https-for-your-wordpress-website/ (Start with “Update your Site URL”)

      Best regards,
      Michael, 1&1

  3. Seb says:

    Hi, I do not see the Activate SSL button in my app center, only Edit Website and Uninstall.. Please Help.

    1. 1and1help says:

      Hi Seb,

      if you don’t see it like in the screenshot above, it’s very likely that you are running a Safe Mode or Standard Mode installation. In this cases, this option is not available by default.

      If you are running a Standard installation, switching to “https” in WordPress is like changing the domain. Here you can find a manual from our Help Center: http://help.1and1.com/hosting-c37630/website-building-tools-c85146/wordpress-c85192/change-your-wordpress-domain-a792489.html

      Best regards,
      Michael, 1&1

  4. Eric says:

    your website absolutely sucks. Trying to follow the three steps above get me nowhere and things you say I should see and activate do not exist on pages. Let me count the way JUST this page sucks.
    1) Open the 1&1 App Center.
    Great I can do that fine.

    2) In the website detail view, click Activate SSL.
    There is NOTHING that says “Detail View” OR nothing like in your screen shot that says “Activate SSL”

    3) Accept the SSL guidelines to activate SSL for your website.
    Since #2 is useless this doesn’t exist as well

    As soon as my contract is up I will gleefully change to ANY other hosting provider. Fucking sloppy

    1. 1and1help says:

      Hi Eric,

      sorry for the confusion. As mentioned in the article obove, the SSL option in the App Center ist only available for WordPress installed in “Managed” mode. When you installed WordPress as “Standard” & have an active SSL certificate for your domain, you can follow theses steps: https://make.wordpress.org/support/user-manual/web-publishing/https-for-wordpress/

      Best regards,
      Michael, 1&1

  5. Lee Norman says:

    Hi,

    If we activate SSL will this mean that we will be using HTTPS? If so does that mean that we will have to resubmit our pages to Google via the Search Console?

    Thanks in advance.

    Premier Sounds

    1. 1and1help says:

      Hi Lee,

      depends on what you are using. If you are using Managed WordPress and you have activated the free SSL certificate for your domain, you can do it like described in this article. If you are using WordPress as a Standard / Free mode installation, you have to change your urls from http:// to https://. Read more here: https://help.1and1.com/hosting-c37630/website-building-tools-c85146/wordpress-c85192/change-your-wordpress-domain-a792489.html

      If you are not updating the Google index automatically with a Sitemap plugin or something similar, resubmitting might be a good choice. Please contact Google support for more informations.

      Best regards,
      Michael, 1&1

  6. Bob Gellman says:

    As far as I know, I am not using Managed WordPress. Or Word Press at all. How do I proceed to activate SSL? Thanks.

    Bob

    1. 1and1help says:

      Hi Bob,

      the easiest way is to open the url of your website with “https” at the beginning instead of “http”. To force visitors to open the “https” site, you can use redirections, best practice: rewrite rule inside a .htaccess file. See more here: http://help.1and1.com/servers-c37684/dedicated-server-linux-c37687/system-security-c37699/redirect-traffic-to-a-secure-url-a731205.html

      Best regards,
      Michael, 1&1

  7. Simon Lucas says:

    Using managed wordpress and tried activating SSL. Got message saying there had been an error, and to use the domain centre.

    Can now access secure version of website if I manually enter https, but redirect is not working. πŸ™

    1. 1and1help says:

      Hi Simon,

      looks like this is fixed now. Everytime I try to open your website with “http” it forwards me correctly to the “https” version.

      Best regards,
      Michael, 1&1

  8. Yolanda says:

    I have the 1&1 Managed WP set up. I have been trying to use the free SSL that was supposed to be assigned. It just has a picture that says Oops…it’s not working. I might want to get a refund for this because nothing has worked well since I signed up this month. Please tell me exactly how to set this up. I have already tried the suggestions on the help documents. Thanks.

    1. 1and1help says:

      Hi Yolanda,

      please contact us via help@1and1.com. We will have a deeper look into this for you.

      Best,
      Michael, 1&1

  9. Bryony says:

    I have 1and1 Managed WordPress Plus contract and 2 wordpress sites. I have activated the SSL certificate for the first site but do I then have to pay extra to activate an SSL certficate for the second site? ie this contract includes hosting of up to 5 wordpress projects but only includes one SSL certificate, so you have to pay extra for any others? Thanks.

    1. 1and1help says:

      Hi Bryony,

      it’s exactly how you described it. First certificate is for free (for each contract), for every additional one you pay an extra fee.

      Best regards,
      Michael, 1&1

  10. Brian Mead says:

    I turned on SSL but when I go to my site url, it still comes up with the http version and I get the parking page. How do I direct the http to the https version? I thought it was done automatically with the managed WP service.

    1. 1and1help says:

      Hi Brian,

      True, the redirect from http to https should work automatically. As I can see, this works now for your website as expected.

      Best regards,
      Michael, 1&1

  11. James Rome says:

    I have a Drupal site. How do I turn on SSL?

    1. 1and1help says:

      Hi James,

      seems like you sorted this out by your own in the meantime. HTTPS on the linked website looks perfect now πŸ™‚

      Best regards,
      Michael, 1&1

  12. Steven says:

    Hi there, I am using 1and1 for my web hosting, i am using a ssl for my website, I have activated it and assigned it to a domain, is that all I have to do?

    1. 1and1help says:

      Hi Steven,

      you might want to check your website for mixed content. Web browsers will only show your website with a green ssl icon, if all of the content on your website is loading with “HTTPS”.

      Read here for more informations:

      https://community.1and1.com/optimizing-ssl-encryption-detecting-removing-mixed-content/

      Best,
      Michael, 1&1

  13. Erika says:

    I have a Managed WordPress site with 1&1 and have activated my SSL certificate for that wordpress site but in wordpress the “WordPress Address (URL)” & “Site Address (URL)” still show it as http://
    How can I get it so that users automatically go to https:// ?
    Thank you!!

    1. 1and1help says:

      Hi Erika,

      we fixed this for you. The call for http will now automatically be redirect to https. πŸ™‚

      Best regards,
      Michael, 1&1

  14. Ken Munro says:

    My WordPress site is running in Safe Mode. I have enabled the free SSL Certificate and can access my site via the https address but it is not automatically routing visitors via the https address. There doesn’t seem to be a way for me to do this in Safe mode. Can you adjust my site please?

    1. 1and1help says:

      Hi Ken,

      please drop us a message at help@1and1.com so we can have a deeper look in your account.

      Thanks
      Martin, 1&1

  15. I have a managed 1&1 WordPress installation and activated SSL against the domain yet http does not redirect to https. Please resolved ASAP.

  16. Mike says:

    Im using magaged WordPress with a SSL certificate installed. It is not being redirected from http to https automatically. Tried emailing help twice with no response. Please fix. Thank you

    1. 1and1help says:

      Hi Mike,

      we want to have a deeper look into this. Can you please email your Customer ID and website to help@1and1.com? We’re happy to assist you.

      Thanks
      Martin, 1&1

  17. Private User says:

    Having search through 1&1 support, contacted support directly several times I have yet to find a clear and transparent answer to my questions. I now seek these answers through this community platform As a hosting provider, 1&1 support, in my opinion, currently remains to be seen.. The main two of many Qs are:

    Q1: Having taken up your offer to upgrade, I am now experiencing more problems across my sites hosted with 1&1. Aside the security and privacy issue yet to be address. I now notice that my current wildcard SSL (which displayed fine prior to upgrade) has the following issues.

    Issue 1: “https://” no longer shows up in the url. Why is this? (note: “www” was never visible post and pre upgrade). Will this have an impact on any links directed to the full https://MYDOMAIN.COM (which showed immediately prior to speaking with 1&1 customer support)? Also does this impact on the speed/loading time of connecting to the site?

    Issue 2: In relation to the above, SSL secure padlock is now replaced with this site is “not secure”, despite not changing anything on it? Why would this be?

    I cannot stress the importance of security both to our company and clients, hence purchasing an SSL that actually works!

    Q2: On installing any WordPress site to 1&1 I have noticed over the past months a “must use” “1&1 Product Subdomain” plugin. As far as I am aware (having searched hours) that there is no documentation, no immediate access through WordPress.org admin platform, to understand what this entails. Now with GDPR implemented in EU, would it be possible to finally get an answer to this question – What is it (full clear explanation)? What type of coding/information does it gather? What is the impact (if any) on data privacy/security?

    All other plugins give some information or contains a link the both the WordPress.org plugin developer page or plugin documentation/support. 1&1 does not do either!

    1. 1and1help says:

      Hi,

      regarding your issues:

      Issue 1:
      Without seeing your domain and the website, it’s hard to say anything about the reasons and how to fix that. If your website shows up with “http” by default, it’s most likely a setting in your website configuration. Assuming that you are using WordPress, you should check if you have configured the site like this in your WP Dashboard and in your .htaccess (to force https): https://help.1and1.com/ssl-certificates-c85183/administration-c85185/ssl-certificate-managed-by-1and1-c85187/set-up-an-ssl-certificate-for-wordpress-standard-installation-a793192.html

      Issue 2: Click here for the changes in latest Chrome: https://www.blog.google/products/chrome/milestone-chrome-security-marking-http-not-secure/ This has nothing to do with us as a hosting company but is a decistion of Google how to handle “http” requests in their popular browser.

      Q2: I am not sure about this “β€œ1&1 Product Subdomain” plugin” you mention here. When you install a WordPress through the 1&1 App Center, we recommend you a bunch of Plugins, but none of them fits to the mentioned name. Can you describe me a bit more where you find this plugin in your Dashboard? I haven’t seen this anywhere around.

      Best regards,
      Michael, 1&1

  18. Simon Lucas says:

    I am running managed WordPress with SSL activated. However it seems each time wordpress is updated we lose the SSL re-direct. Each time I contact support and get told to switch to a standard install so I can make the changes. Slightly frustrating to say the least as I am paying for the managed service and would expect this to be resolved!
    My wife also sees the same with her sites. starting to think I need to switch providers πŸ™

    1. 1and1help says:

      Hi Simon,

      From my experience: Once SSL is correctly activated for your Managed WordPress installation, this configuration will not be overwritten by future WordPress updates.

      However, I did some small adjustments to your installation which should prevent this behaviour in the future. If this should happen another time, please send us an e-mail to help@1and1.co.uk and we will look at it again.

      Best regards,
      Michael, 1&1

  19. I have activated SSL/HTTPS but can’t see how to force HTTPS if I use HTTP. Can you please advise how i set this up?

    1. 1and1help says:

      Hi,

      I had a quick look into your customer data, but wasn’t able to see an activated SSL certificate.

      Please activate your SSL like this :

      https://help.1and1.co.uk/ssl-certificates-c85276/administration-c85278/ssl-certificate-managed-by-1and1-c85280/set-up-an-ssl-certificate-for-hosting-packages-a765863.html

      After you have done this successfully, please call up our support team: https://contact.1and1.co.uk/ They will assist you with the activation an forcing to https for your application.

      Best regards,
      Michael, 1&1

Leave a Reply to Karen Cancel reply

Your email address will not be published. Required fields are marked *